Issues loading apps
Incident Report for Bubble
Resolved
If you are still experiencing issues, please clear your browser cache.

For more discussion of what happened, see: https://forum.bubble.io/t/is-bubble-completely-down/68867/47
Posted 14 days ago. Oct 09, 2019 - 10:27 EDT
Investigating
We are still investigating
Posted 14 days ago. Oct 09, 2019 - 09:57 EDT
This incident affected: Main Bubble Cluster.