Bubble Forum Unavailable
Incident Report for Bubble
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 12:21 EDT
Investigating
Our automated systems have detected that the Bubble forum is currently unreachable. We are investigating the issue...
Posted Mar 22, 2023 - 12:01 EDT
This incident affected: Bubble Forum.