Bubble Forum Unavailable
Incident Report for Bubble
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 19:17 EDT
Investigating
Our automated systems have detected that the Bubble forum is currently unreachable. We are investigating the issue...
Posted Sep 03, 2021 - 19:05 EDT
This incident affected: Bubble Forum.