Increased latency on editor and runmode

Incident Report for Bubble

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 14:07 EDT

Monitoring

We determined the issue was related to how we distribute work between apps, and noticed an issue where a single app was able to do more work than should have been possible.

We're working on the more permanent fix now, but we put mitigations in place to avoid this in the short term and are monitoring.
Posted Sep 04, 2025 - 13:36 EDT

Investigating

We have noticed increased latency on page loads and are investigating the cause now.
Posted Sep 04, 2025 - 12:15 EDT
This incident affected: Bubble Core (Main Bubble Environment, Bubble Editor).