Degraded performance on fetching workload units for the app

Incident Report for Bubble

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 20:00 EDT

Update

Some of the workload charts are still experiencing degraded performance. We are working on a long-term fix.
Posted Sep 24, 2025 - 12:06 EDT

Monitoring

We have successfully identified one root cause of the workload units engine malfunctioning, which had to do with query performance against a third party database that powers workload usage.
We have implemented a short term fix that should allow all the charts to load properly.
We are communicating with the our vendor to make sure that this service's underlying engine will durably preserve the mitigation we put in place, in order to guarantee predictable performance and stability on this service.
Posted Sep 23, 2025 - 20:35 EDT

Update

We have limited the scope of the behavior so that loading apps is fast now. We are still investigating why it's slow to load workload charts on editor.
Posted Sep 23, 2025 - 12:59 EDT

Investigating

We have identified degraded performance on fetching workload units. It could affect loading apps on editor or viewing workload usage on the app. We have not found any evidence that it affects runtime performance.
Posted Sep 23, 2025 - 05:15 EDT
This incident affected: Bubble Core (Bubble Editor).