Bubble.io unexpected loading errors

Incident Report for Bubble

Resolved

Earlier today, our internal load balancer experienced intermittent connection issues with core servers, causing a portion of requests to fail.

The engineering team has implemented mitigations to restore service and have fully identified the root cause. A long-term fix is being developed to improve resilience against this type of issue in the future.

Services are now operating normally.
Posted Aug 21, 2025 - 17:27 EDT

Monitoring

Bubble has come back up, we are monitoring and continuing root cause analysis.
Posted Aug 21, 2025 - 15:30 EDT

Update

We are continuing to investigate this issue.
Posted Aug 21, 2025 - 14:45 EDT

Investigating

We are currently investigating bubble.io returning unexpected errors
Posted Aug 21, 2025 - 14:45 EDT
This incident affected: Bubble Core (Main Bubble Environment, Bubble Editor).