Resolved
All errors are resolved.
Monitoring
We have fixed the SSL/TLS issues w/ these domains and are monitoring.
Identified
An issue w/ TLS/SSL certificate termination has been identified.
Investigating
Some dedicated customers are down, seeing SSL/TLS errors.