Increased latency
Resolved·Degraded performance

The fix has been deployed and the issue has been resolved.

Fri, Nov 14, 2025, 03:47 PM
(5 days ago)
·
Affected components
Updates

Resolved

The fix has been deployed and the issue has been resolved.

Fri, Nov 14, 2025, 03:47 PM

Identified

We are deploying a fix for this issue shortly, expect another update in the next 30 minutes

Fri, Nov 14, 2025, 03:12 PM(34 minutes earlier)

Investigating

We are observing increased latency on our main cluster and investigating

Fri, Nov 14, 2025, 02:12 PM(59 minutes earlier)