Resolved
Global DNS propagation has completed.
Monitoring
The DNS issue has been resolved for most regions but is continuing to propagate globally.
Monitoring
A fix has been implemented and we are waiting for propagation to complete.
Identified
We have identified the issue and are working on a fix.
Investigating
We are continuing to investigate this issue.
Investigating
We have detected and are investigating the issue where Security Dashboard is unreachable due to DNS issues.