Resolved
Logs appear to be working normally again.
Monitoring
We took steps to restore functionality to the server logs panel, we will monitor the situation to see if it is stable and fully resolved.
Investigating
We are currently investigating an incident causing server logs to not be displayed.