Noticing slightly elevated page load metrics
Resolved·Degraded performance

Our rollback went out ~2:50PM ET and our metrics are now in a healthier state.

Tue, Nov 25, 2025, 09:27 PM
(5 days ago)
·
Affected components
Updates

Resolved

Our rollback went out ~2:50PM ET and our metrics are now in a healthier state.

Tue, Nov 25, 2025, 09:27 PM

Identified

We’ve identified a commit that put more CPU pressure on our servers and are in the process of rolling that back

Tue, Nov 25, 2025, 07:01 PM(2 hours earlier)

Investigating

Our internal metrics are showing some slightly elevated page load performance that we are investigating now.

Tue, Nov 25, 2025, 05:27 PM(1 hour earlier)